通达信天机线指标选股公式及源码,通达信主力专用指标

通达信dkx买卖选股公式

通达信 DKX 多空线(系统)通达信系统自身指标,DKX自身指标为副图,为方便你的认识,改为主图、增加选股。(注:如有疑问你自己去问一下通达信老板)
DKX 多空线源码由下面组合成;

MID:=(3*收盘价+最低价+开盘价+最高价)/6;
DKX:(20*MID+19*向前引用(MID,1)+18*向前引用(MID,2)+17*向前引用(MID,3)+16*向前引用(MID,4)+15*向前引用(MID,5)+14*向前引用(MID,6) +13*向前引用(MID,7)+12*向前引用(MID,8)+11*向前引用(MID,9)+10*向前引用(MID,10)+9*向前引用(MID,11)+8*向前引用(MID,12) +7*向前引用(MID,13)+6*向前引用(MID,14)+5*向前引用(MID,15)+4*向前引用(MID,16)+3*向前引用(MID,17)+2*向前引用(MID,18)+ 向前引用(MID,20))/210;

其实DKX指标是一个在事后来看很准的一个指标,由于DKX指标不受短期波动的影响,滞后性是肯定的。
DKX指标实际上就是个“看上去很美”的指标,但是却是很难把握其运用时机的指标。

多空线主图 源码:

MID:=(3*CLOSE+LOW+OPEN+HIGH)/6;
DKX:=(20*MID+19*REF(MID,1)+18*REF(MID,2)+17*REF(MID,3)+
16*REF(MID,4)+15*REF(MID,5)+14*REF(MID,6)+
13*REF(MID,7)+12*REF(MID,8)+11*REF(MID,9)+
10*REF(MID,10)+9*REF(MID,11)+8*REF(MID,12)+
7*REF(MID,13)+6*REF(MID,14)+5*REF(MID,15)+
4*REF(MID,16)+3*REF(MID,17)+2*REF(MID,18)+REF(MID,20))/210;
MADKX:MA(DKX,10),DOTLINE;
IF((MADKX>=REF(MADKX,1)),MADKX,DRAWNULL),LINICK2,COLORMAGENTA;
IF((MADKX<=REF(MADKX,1)),MADKX,DRAWNULL),LINICK2,COLORGREEN;
选股:=CLOSE>=DKX  AND CROSS(DKX,MADKX);
DRAWICON(选股,L*0.96,30);


选股公式 源码:
MID:=(3*CLOSE+LOW+OPEN+HIGH)/6;
DKX:=(20*MID+19*REF(MID,1)+18*REF(MID,2)+17*REF(MID,3)+
16*REF(MID,4)+15*REF(MID,5)+14*REF(MID,6)+
13*REF(MID,7)+12*REF(MID,8)+11*REF(MID,9)+
10*REF(MID,10)+9*REF(MID,11)+8*REF(MID,12)+
7*REF(MID,13)+6*REF(MID,14)+5*REF(MID,15)+
4*REF(MID,16)+3*REF(MID,17)+2*REF(MID,18)+REF(MID,20))/210;
MADKX:=MA(DKX,10);
选股:CLOSE>=DKX  AND CROSS(DKX,MADKX);

求教高人把通达信指标公式做成选股指标 源码如下:

直接就可以选股了,不用改动

通达信主图指标源码,求老师看有没有未来,并帮改成选股和预警公式,谢 ...

1、是否有未来,你直接引入,现在的通达信版本可以直接显示出来。
2、选股你想要什么信号条件啊?
3、通达信因为软件自身的因素,在盘中是无法正确预警的。

通达信ene指标选股公式

UPPER:=(1+6/100)*MA(CLOSE,25);
LOWER:=(1-6/100)*MA(CLOSE,25);
ENE:=(UPPER+LOWER)/2;
XG:L<LOWER*1.01;
精简为:

LOWER:=(1-6/100)*MA(C,25);
XG:L<LOWER*1.01;

求通达信可用的基本面选股公式

(每股净资产+每股未分配利润+每股资本公积金)/股价小于1.5且过去三年ROE大于10%的选股公式。

通达信选股公式

涨停回落:H/REF(C,1)>1.096 AND C<H;

因通达信不支持分时动态选取数据,你想收市后选股,现阶段不可能实现。只能改为11.30分停市时1点开市前就要进行用上面公式进行选取。
仅供参考,祝你好运!

返回顶部