当前位置:首页 > 问答

通达信倒数k线根数源码

我来帮TA回答

老师你好:可以给编一个通达信的K线倒计时指标吗?

通达信没有编写此类公式的函数,不能满足你的要求。

请高手帮忙,倒数第5根K线收盘价画一条横线,编写一个通达信主图公式

const(ref(c,4));

根据揉搓线写个通达信k线源码,要求是第二根正T实体部分用黄色,下影线下方用红色的“一”标注。麻烦您

AA:=(REF(H,1)-MAX(REF(C,1),REF(O,1)))/(REF(H,1)-REF(L,1))>0.7 AND (MIN(O,C)-L)/(H-L)>0.7;
STICKLINE(AA,O,C,1.5,0),COLORYELLOW;
DRAWTEXT(AA,L*0.98,'_ '),COLORRED;

通达信源代码

{当五日均线上穿八日均线,且济安线X线上穿济安线 且MACD的绿柱缩减,CR 线在箱体内在主图上显示B }
五日均线:=MA(C,5);
八日均线:=MA(C,8);
CRMA0:=CR.CR;
CRMA1:=CR.MA1;
CRMA4:=CR.MA4;
MACD:=MACD.MACD;
X:=JAX.A;
济安线:=JAX.济安线;
看信号:CROSS(五日均线,八日均线) AND CROSS(X,济安线)
AND CRMA0>CRMA4 AND CRMA0<CRMA1 AND MACD>REF(MACD,1) AND MACD<0,NODRAW;
DRAWICON(看信号,L,7);
-----------------------------

我看了一本大智慧公式的说明书,里面讲到穿头破脚时,我觉得是不对的,各位看一下是不是它写错了?

A1:=REF(CLOSE,1);
A2:=REF(OPEN,1);
BB:=OPEN/CLOSE>1.04;
B1:=OPEN<A1;
B2:=CLOSE>A2;
BB AND B1 AND B2;
-------------------
费了不少功夫呢,请采纳

求昨日阳线今日阴线的通达信选股公式,只要满足昨日是阳线今日是阴线,今日量比昨日低就行

XG:REF(C>O,1) AND O>C AND V<REF(V,1);
(已测试通过,不过选出来的股很多啊)